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Conventions used in this manual

The following typographic conventions are used in this manual to indicate
various types of information:1

Menu→Item Menu paths in the graphical user interface of MAGI are shown
as slanted, bold text in dark green separated by a right arrow →. The
arrow indicates a branch to a submenu.

command Unix commands are shown as bold text printed in sans sarif.

arguments Arguments to Unix commands are shown as slanted text.

button Buttons that can be selected are displayed as underlined text.

1Please note that for the ease of reading color is used throughout the manual. However,
color is never the only distinguishing characteristic feature between two items. A black
and white copy of this document is also available for printing.
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Introduction

MAGI is a tool with a graphical user interface (GUI) that supports users
in performing geometry-based numerical analyses2. Its main capability is
two-fold: First, it visualizes geometric models, second it offers the ability to
create meshing and analysis attributes. The attributes can subsequently be
read by meshing tools and analysis tools to create the mesh and perform the
desired analysis.

With respect to the visualization MAGI currently supports models from
the commercial modeler Parasolid, Shapes, and Pro/Engineer, as well as a
SCOREC internal discrete modeler format. It provides the usual functionali-
ties of zooming, rotating, and translating the model. For creating attributes,
it supports features specifically needed to be able to apply attributes to the
geometric model, e.g. picking topological entities of the model so that at-
tributes can be associated with them.

In particular, attributes can be set to

• control the automatic meshing of the geometric model

• apply boundary conditions and material parameters to define the nu-
merical problem

• choose the solution methods being applied to solve the numerical prob-
lem

This document provides information on the functionality of MAGI regarding
the visualization on geometric models, and then focuses on attributes needed
to fully describe the numerical analysis, and to mesh the geometric model.

2Geometry-based numerical analysis is understood as an analysis based on a toleranced
non-manifold geometric model as defined within commercial CAD systems
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Visualization of Geometric Models

1 Starting MAGI

Figure 1: MAGI start up screen

MAGI is started by the command

mgi modeler

where modeler needs to be replaced by

• shapes,

• parasolid

• proe
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• discrete

depending on the model you are working with, as well as the configuration
of mgi you have licensed. MAGI will open a window as displayed in figure 1.

2 Loading a model

Figure 2: Model selection box

The first thing you most likely want to do is to load a geometric model
into MAGI. From the three menus (File, Edit and View) that are offered
choose

File→Load Model

That will open up a file selection window, see figure 2. Depending on
the modeler configuration you are running, MAGI will display all loadable
models, determined by the file extension that is typical for the modeler. In
this example MAGI is displaying all loadable shapes models in the current
directory. You can select the model you want to load, and MAGI will activate
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the Load button. If your model is not available in the current window you can
set the directory containing the model by changing the “Current directory
is” input box in the selection window. Also, if you have chosen to give your
model a different file extension than what is recognized by MAGI you can
force MAGI to display your file name by modifying the “Current filter is:”
input box accordingly. Please press ENTER to have the changes be active.

After clicking the Load button MAGI will load the model and display it
in the main window. The MAGI window should display your model as shown
in figure 3.

Figure 3: Model Display

3 Mouse Control

You can rotate the model by holding the left mouse button while moving the
mouse. The middle mouse allows to translate the model in any direction. To
zoom in and out of the model the right mouse button has to be pressed while
the mouse is being moved up or down. Up movement results in zooming
out of the model, a down movement results in zooming into the model. In
case the model is lost on the screen due to accidently zooming, translating or
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rotating it out of the view the menu View→Reset View (or the keyboard
combination Ctrl-r) can be used to reset the graphics to the original state.

4 Model Options

There are various ways to change the way the model is displayed. The menu
Edit→Model Preferences brings up the window, as displayed in figure 4
to control the parameters.

Figure 4: Model Options

The Model Options window provides a menu to change the color of the en-
tities being displayed. In the Model Options window choose Color→Vertex
to open a color selection window that lets you pick from a set of predefined
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colors, or you can define the color by setting the red, green and blue values
using the sliders. By hitting the accept button the color of the vertices in the
model will take on the color being chosen. The colors for model edges, faces
and regions can be changed in the same fashion. Further parameters can be
set and/or changed via the toggle buttons and sliders in the Model Options
window. The following list gives a detailed descriptions of the parameters
and their use:

Model Tolerance. The tolerance value changes the granularity of the dis-
play. Smaller values results in a better resolution of curved features
while on the other hand they slow down the visualization process.

Model Scale. The model can be scaled in x, y, and z direction by the given
values. Default is a scale value of 1.0 which means no scaling at all.

Model Entity Display Control. The Model Entity Display Control al-
lows specification of the topological entities that are to be displayed.
By selecting the button for an entity type all entities of that type will
be made visible. Deselecting the button will make the entities invisible.
Note that regions are only visible if the faces are being deselected or
made transparent.

Model Enhancement Display Options. The Model Enhancement Dis-
play Options allows enhanced visualization of model vertices by draw-
ing a sphere around them. Model edges are enhanced by drawing a tube
instead of a thin line. The sphere radius as well as the tube radius can
be set in the input boxes.

Rendering Options. This option switches between “No culling”, “front
culling” and “back culling”.

Face Transparency. The slider lets you choose the transparency of the
model faces. Increasing the transparency will give a look through effect
where the faces become more and more transparent until they disappear
completely if a value of 1.0 is chosen.

Region Transparency. Similar to the previous topic this slider lets you
choose the transparency of the model regions. Note that the regions
have to be selected in the Model Entity Display Control, and the model
faces have to be deselected (or made transparent) before the model
regions can be visualized.
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Show Axes. Allows to turn the model axes on or off.

Save Model Preference. Saves the current setting of the preferences to a
file. A file selection box lets you define a file name. That file can be
read in by selecting from the menu Edit→Load Model Preferences.

Save Default Preferences. Save the current setting of the preferences as
the default. The next time MAGI is being started the preferences will
be reused automatically.

Figure 5: Selection Control Window

5 Selecting model entities

MAGI lets you select topological entities from the model. This feature is cen-
tral to the attribute specification process. First, from the menu View→Selection
Controls has to be selected. This will bring up an additional window as dis-
played in figure 5.
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To select a model entity move the mouse close to the entity that you
want to select and hit the key “p” on the keyboard. MAGI will highlight
the selected entity as shown in figure 6. In the Selection Control window
(figure 5) the box “Selected Entity” shows the type of the model entity that
was selected (Vertex, Edge, Face or Region) and the tag of that entity as
provided by the modeler. The button Hide Selected removes the display of
the entity that is highlighted. This is a useful feature if model entities in
the interior of a model need to be selected since hiding the exterior model
entities will allow seeing into the interior of the model. By hitting “Display
All” all previously hidden entities will be displayed again. The sub-window
“Associated Attributes” provides a list of attributes that have been asso-
ciated with the selected model entity, if any. The sub-window “Available
Attributes” displays a list of attributes that could be associated with the se-
lected attributes. Those sub-windows will remain empty unless an Attribute
Manager has been created or loaded. We will therefore come back to asso-
ciating attributes with model entities when the Attribute Manager has been
described. The button Select Model offered in the selection controls window
is also only useful with regard to the association of attributes to the model.
The menu color offers the choice to change the color being used to highlight
the selected entity.

Tip: It is helpful to disable the type of model entities that don’t need to
be selected using the Model Options window ( Edit→Model Preferences).
That increases the chance that the correct entity is being selected, and not
another entity that lies close to the one that is supposed to be selected.

6 Visualizing Finite Element Meshes

MAGI can visualize Finite element meshes if the mesh is stored in the
SCOREC Mesh File Format. That file format is the default output file
format if MAGI is being used to generate the mesh.

To load a mesh the corresponding model has to be loaded.3 If the model
is loaded choose

File→Load Mesh

3Make sure the the mesh you are trying to load was generated based on the model that
has been loaded. MAGI will not work properly otherwise.
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Figure 6: Highlighting of selected model entity

A file selector box similar to the one in figure 2 will appear that shows
all files with the ending .sms, which is the default ending of meshes stored in
the SCOREC Mesh File Format. Select the mesh you want to visualize and
hit the Load button (or double click the name of the mesh in the file selector
box). That will load the mesh into memory and display it on the screen.

To modify the mesh display on the screen choose

Edit→Mesh Preferences

The Mesh Options Window will open. The options offered in the Mesh
Options window are a subset of the model options. Mesh entities can be
turned on or off, mesh vertices and edges can be enhanced, and the mesh
faces can be made transparent. The features are identically to the ones
offered in the Model Options window, but the target are mesh entities instead
of model entities. Please refer to figure 4 and the explanations given for more
information on the mesh options.

At this point the model and mesh entities are displayed both at the same
time. To display the mesh without interference through the model entities
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deselect the model entities through the Model Options Window (see figure
4). See e.g. figure 11 for an example of a mesh displayed in MAGI.
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SCOREC Attribute Structure

We will have to introduce the basic structure of attributes as they are
represented in the SCOREC attribute system to be able to describe MAGIs
functionality in an effective way.

The most important structure in the attribute system is the attribute
node. There are three basic types of attribute nodes:

Information Nodes: used to represent basic information

Group Nodes: used to represent hierarchical information

Case Nodes: used to represent a complete description for a specific analy-
sis.

Figure 7: Attribute Node
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Information Nodes store the information that is to be associated with the
model or model entities. The type of information can be an integer, a double
precision floating point, a string, a tensor value or void. The void informa-
tion serves simply as a boolean flag, i.e. it is possible to inquire whether
the attribute is there or not. Information Nodes can get their value from
expressions that can be either dynamic (changing during the run time of the
analysis) or static. Group Nodes group information together by referencing
other Attribute Nodes. Figure 7 shows how MAGI represents an attribute
node as shown on the screen. To the left an Information Node holding a
string is being displayed. The information stored is simply the name of the
file containing the mesh being used for the analysis. To the right a Group
Node is displayed. The attributes grouped together are the six material pa-
rameters for a non-linear material law. Although the two attribute nodes
displayed in the figure hold quite different type of information, both show
the same header revealing the common characteristic of an attribute. Each
attribute node consists of:

• Attribute Node Name

• Information Type

• Image Class

The Attribute Node Name is defined by the user and is provided only for
the convenience of users helping them to identify the attribute. Attribute
Node Names don’t have to be unique.

The information type and the image class are defined by the application
using the attribute information. You won’t have to learn more details about
the information type and the image class unless you want to write your own
application, and use MAGI as a tool to set up your analysis. If you are
using the SCOREC mesher or the SCOREC analysis framework Trellis you
will have a predefined set of attributes that should enable you to select the
attributes you need from the menu, and simply provide the needed values.

At this time we do not explain the Case Nodes since the user of MAGI
does not directly deal with Case Nodes. There are three cases being created
automatically when an Attribute Manager is created, which are explained in
the next section.
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Creating Attributes

1 Attribute Manager

Figure 8: Attribute Editor

After the basics of the SCOREC Attribute System have been explained
we will now present how attributes are created and associated with model
entities. The first step in the process is the creation of an Attribute Manager.
Choosing the menu File→New Attribute Manager will bring up a window
where the name of the Attribute Manager has to be specified. The name has
no significance other than to help the user identify the analysis attributes to
be set up. After pushing the Create button the Attribute Editor window will
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open up, see figure 8. The window is subdivided into three parts, where the
first part shows the problem specific attributes, the second part the numerical
attributes, and the third part shows the meshing attributes. Each of those
sets of attributes will be stored as a separate case in the attribute database.

Problem specific attributes are all those attributes that are needed to
create a well posed problem, i.e. they contain boundary conditions and
material parameters. They can be thought of as those attributes that a
mathematician or an engineer would need in addition to the domain to solve
the problem analytically.

The numerical attributes define the set of information that is needed
for the solution of the problem using a numerical analysis method. Finite
Difference methods, Finite Element methods, Partition of Unity methods are
examples of numerical methods that need more information than provided
through the problem specific attributes. Typical numerical attributes are the
type of linear solver being used to solve the arising system of linear equations,
the type of time integrator for time dependent problems etc.

Meshing attributes are being used to control the discretization process
of the geometric model. Typically, the element size needs to be controlled
during the meshing procedure. Meshing attributes allow you to do that in
various ways.

Problem specific attributes and meshing attributes have to be created
using the Attribute Manager, and need to be associated with the topologi-
cal entities of the geometric model in a second step. The association of the
attributes with the geometric model is a task that is similar to all types of
attributes being created. See the section “Attribute Association” for infor-
mation on this.

While MAGI allows to create attributes from scratch in the Attribute
Manager, there is usually a certain set of attributes that would be used with
a particular application. E.g. a linear structural mechanics analysis will
most likely need to apply loads and displacement boundary conditions, while
a meshing application needs to set mesh size attributes. MAGI can load
such a set of pre-defined attributes from a file to be able to customize it for
a specific application. Choose

File→Load Problem Definition File

from the menu in the Attribute Editor. That will open a file selector box
in which the problem definition file (ending .probdef) needs to be selected
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and loaded. The MAGI distribution contains at least one problem definition
file that contains the attributes for meshing (meshing.probdef), which needs
to be loaded in order to be able to control the meshing procedure. The
attributes are pre-defined to work with the SCOREC mesher application
which is based on the MeshSim mesher kernel.

The following sections describe the specification of the attributes from the
three groups described in this paragraph in more detail. We will show how
a complete analysis for an elasticity problem can be specified using MAGI.

2 Problem Specific Attributes

Problem specific attributes are all the attributes that are needed to define a
well posed problem. Boundary conditions – including initial conditions for
time dependent problems – and material parameters fall into this category.

The problem we are looking at is the screwdriver that already appeared
in a couple of pictures. We will be setting up an analysis simulating the
displacements of the screwdriver while using it for its purpose, i.e. screwing
in a screw. We assume that the screwdriver is held in place at the grip, and
that a torsion moment is applied to its tip. Those boundary conditions are
close enough to the actual loading (grip is rotated, tip is held in place by the
screw), and it allows us to simulate the tip loading better by applying linear
varying load instead of a full contstraint (not realistic) or a complex contact
analysis.

We start out with constraining the displacements on the grip. As men-
tioned before we completely constrain the displacements in all directions,
and we will apply that constrain to the outmost faces at the grip of the
screwdriver. Choose

Edit→Create Pre-defined→Prob. Spec→displacement→disp
vector

That will bring up a window where the name of the new Attribute Node
can be specified. Here we choose to name the attribute “grip constrain”. Af-
ter hitting the Create button, the attribute editor window (see figure 8) will
contain the attribute that was created. Double clicking on the new attribute
will open up a new window (figure 9) that allows us to specify the compo-
nents of the displacement constrain. Since the grip is supposed to be fully
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constrained we enter a 1 in each of the input boxes for the three components.
A zero would indicate that a specific component is not constrained. Hitting
the accept button will finish that operation.

Figure 9: Specification of displacement constrains.

The load that needs to be applied to the tip of the screwdriver is not
constant since we decided to apply a more realistic linear varying load. The
SCOREC attribute system contains an expressions system that allows ap-
plication of any function with the coordinates and the time as independent
values. In our case the screwdrivers axes is falling on the z-axis, and the
edges of the tip are aligned with the x-axes. We assume that the load can
be computed using the function f(x) = 4.0 ∗ x where x is the value of the
x-coordinate. Once again we create a new attribute node by choosing

Edit→Create Pre-defined→Prob. Spec→load

This time we name the attribute node “tip momentum”. After creating
the attribute node and double clicking on the new attribute in the Attribute
Editor window we are presented with a window where the x, y and z values
for the load can be entered. The x and z value are being set to 0, and for the
y value we enter 2.0 ∗ x1. 4 x1 is the keyword in the expression system that
stands for the x coordinate. x2 and x3, respectively, would represent the y
and z coordinate.

4We choose half of what needs to be specified in total since we are going to apply that
load to the two edges at the tip of the screwdriver.

20



The last attribute that needs to be specified to complete the problem
specific attributes is the attribute specifying the material. From the menu
we choose

Edit→Create Pre-defined→Prob. Spec→deformable
material→linear elastic isotropic material

We assume that the screwdriver shaft is made out of steel, and name the
attribute correspondingly. Double clicking on the new attribute allows to
enter the material parameter for the Young’s modulus 21 ·106N/cm2 and the
poisson’s ratio of 0.283. We create a second material for the grip which we
assume is made out of hard plastic: Young’s modulus 8 · 106N/cm2

, poisson’s
ratio 0.35.

All the problem specific attributes needed for the linear elastic analysis
are now created, and as the next step the numerical attributes need to be
specified.

3 Numerical Attributes

The SCOREC analysis framework holds solution information in fields. This
is in contrast to classical Finite Element packages that have you specify cer-
tain element types out of a given list. The approach using fields is more
versatile since it separates the interpolation of the solution and the mapping
from the element formulation. One element formulation can therefore be
used with different shape functions (hierarchic, lagrange) of different polyno-
mial order with different types of mapping (mesh mapping, exact geometry
mapping). In our elasticity analysis one field is needed to hold the displace-
ment information, which is the primary unknown for the formulation chosen.
Further fields may be necessary for more complex element formulations, e.g.
an element formulation interpolating displacement and pressure (“mixed el-
ement formulation”) would require a second field. A field can be created by
choosing

Edit→Create Pre-defined→Numerical →field

21



The name of the field needs to be synchronized with the application us-
ing the attributes. The elasticity analysis expects the field to have the name
“displacement” which is how we name the field. Double click on the new
created attribute gives the possibility to set its parameters (see figure 10).
A field needs to know how the information obtained on a standard unit el-
ement is being mapped into the element in the real mesh. Currently “mesh
mapping” and “exact mapping” is being supported. “Mesh mapping” is a
linear mapping between the standard element and the element in the mesh,
while “exact mapping” maps the standard unit element to the exact geom-
etry as defined by the geometric modeler. In most cases “mesh mapping”
will do a good job which we choose here. The interpolation function can be
specified to either “Lagrangian” or “Hierarchic”. Hierarchical shape function
allow to specify higher polynomial order (currently up to the order 10 if the
SCOREC Analysis Framework is used) while Lagrangian shape functions are
typically limited with respect to the polynomial order. Currently only lin-
ear or quadratic Lagrangian shape functions are supported in the SCOREC
analysis framework. Here we choose hierarchic shape functions. For the
polynomial order we choose “two” which is a good compromise between ac-
curacy and solution time. The dimension is being set to “3” since we solve
a 3-dimensional problem. That will finish the specification of the field. Note
that some of the options might not be applicable if something other than
the SCOREC analysis framework is being used to solve the problem. Exact
mapping e.g. can only be supported in a fully geometry based environment.
Most commercial FE-analysis packages do not provide that functionality.

The name of the mesh input file is another attribute that needs to be
specified. It can be specified through the menu

Edit→Create Pre-defined→Numerical →mesh name

The remaining attribute that needs to be specified is the type of solver
being applied to solve the problem. Typically, three levels of solvers need to
be given: The time integrator that handles the marching in time, the sytem
solver that solves the possibly non linear equations, and the linear solver
that is responsible for obtaining the solution of a linear system of equations.
For this example there is no time dependency, giving us the opportunity to
choose
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Figure 10: Specification of field parameters.

Edit→Create Pre-defined→Numerical →temporal solver→static
solver

After creating that attribute a double click will let us specify the system
solver and the linear solver. The problem is linear, accordingly we choose
the linear solver as the system solver. For the system solver we choose the
direct solver.

4 Meshing Attributes

MAGI provides an interface to the SCOREC mesher, which uses MeshSim
from Simmetrix Inc. (see [2]) for the actual meshing of the geometry. Mesh-
Sim is a commercial meshing library whose roots go back to the geometry
based meshing environment (MEGA) developed at SCOREC [1]. MeshSim
automatically generates both surface and volume meshes starting from a
non-manifold CAD model.

The meshing procedure is executed in two steps. First, a surface mesh
is constructed. Second, based on the surface mesh a volume mesh can be
generated. The mesh generation is controlled by applying meshing attributes
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to the geometric model. Currently, the following types of attributes are
supported to guide the mesh generation process:

• Mesh element size - sets the initial size of mesh entities for model
entities.

• Curvature-based mesh refinement - controls the geometric approxima-
tion between the model and the straight-edged mesh.

• Mesh generation attributes - allow to control the mesh generation pro-
cedures.

The following sections 4.1, 4.2 and 4.3 show how the mesh control at-
tributes are created.

4.1 Mesh element size

Mesh element sizes control the mesh face sizes and gradation during the
surface mesh generation5.

To create a mesh size attribute choose the menu

Edit→Create Pre-defined→Meshing→ mesh size

A new window will appear where the name for the attribute node can be
given. After hitting Create a new attribute node for the mesh size will be
created. It will appear in the Attribute Editor in the Meshing Attributes sub-
window. Double clicking on that Attribute Node will bring up a new window
where the type and the size can be set. The type can be set to absolute
or relative via a toggle button. If the button is set to absolute the mesh
generated will have an edge length that is approximately the value given to
the size parameter. However, the geometry might make it necessary that
a finer mesh must be generated than specified in order to generate a valid
mesh. If the button is set to relative and the size is given a value between
0 and 1 the mesh size will be the length of the largest edge of the bounding
box of the entity multiplied by the specified size parameter.

5Please see also the MeshSim user manual [2] for a more background on the attributes
described in this chapter
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Figure 11: Mesh created without specifying mesh control attributes

Figure 11 to figure 13 show the effect of mesh element size control on
the meshing process. Figure 11 shows a mesh that was created without any
meshing attributes. In this case the mesher attempts to create a mesh with
reasonable size changes. Figure 12 presents a mesh constructed based on
defining a global mesh size attribute. In this example the mesh was globally
refined due to the rather insufficient model approximation of the coarse mesh.
In figure 13 the meshing process was controlled by additionally defining local
mesh size control to generate a refined mesh around the tip of the metal shaft
of the screwdriver to improve the approximation of the stress concentration
in that area. Figure 14 shows the refined mesh around the tip in more detail.

4.2 Curvature-based mesh refinement

Curvature-based mesh refinement controls the geometric approximation be-
tween the model and the straight-edged mesh. The smaller the value, the
more accurately the mesh approximates curved boundaries.

To create a curvature refinement attribute choose the menu
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Figure 12: Mesh created with global mesh control

Edit→Create Pre-defined→Meshing →curvature refinement

A new attribute node will be created. Double clicking on that Attribute
Node will bring up a new window where the curvature parameter and the
minimum size can be set. The curvature parameter is the size relative to
the element size, d

h
as given in the figure 15 (e.g. the mesh size h is selected

that d
h

< par. par should always be less than 0.5. Useful values for par are
typically in the range of 0.01 to 0.4 (smaller value = more refinement). The
minimum size limits the curvature refinement which otherwise can cause an
undesired amount of refinement in some cases.

4.3 Mesh generation attributes

The name of the output file that contains the mesh information can be se-
lected using the menu item

Edit→Create Pre-defined→Meshing→output mesh name
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Figure 13: Mesh created with global and local mesh control

If this attribute is not specified the default name “mesh.sms” will be given
to the file.

The meshing procedure creates a volume mesh consisting of tetrahedral
elements per default. If only a triangular surface mesh is needed, the volume
mesh generation can be turned off by creating the attribute “generate volume
mesh” from the menu

Edit→Create Pre-defined→Meshing→generate volume mesh

Double clicking on the attribute after it has been created allows us to
turn off the volume mesh generation.
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Figure 14: Mesh created with global and local mesh control: Detail

Figure 15: Definition of curvature parameter
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Attribute Association

Some attributes that have been created through the Attribute Editor
need to be applied to model entities or the model, respectively, to make
sense. Most meshing attributes and most problem specific attributes fall
into that category.

To apply an attribute to model entities the entity in question needs to
be selected as described in section 5 of the first chapter. The sub-window
“Associated Attributes” will provide a list of attributes that have been as-
sociated with the selected model entity, if any. The sub-window “Available
Attributes” displays a list of attributes that could be associated with the
selected attributes (see figure 5). To associate an attribute from the list of
available attributes with the selected model entity simply click on the at-
tribute in the sub-window “Available Attribute”. The selected attribute will
appear in the window displaying the associated Attributes. To remove an at-
tribute from the attributes that are being associated with the selected model
entity select the attribute in the list of associated attributes. The attribute
will dissapear from the sub-window “Associated Attributes” and will now
appear again in the list of available Attributes.
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Creating and using Attribute Files

The created attributes can be written into an attribute file by choosing
the menu

File→Save Attribute Manager

The program will ask for the name of the attribute file that will be cre-
ated. Usually attribute files should carry the extension “.atdb”. After the
filenmane has been entered into the “Selected file:” box the Save button is
active and can be selected to save the file. The file is the input file for the
SCOREC Mesher as well as the SCOREC analysis framework Trellis.

The attribute file can also be loaded into MAGI after a MAGI session
has been ended. After MAGI has been started choose

File→Load Attribute Manager

The program will ask for the name of the attribute file. The file selector
box will show all the files ending with “.atdb” in the current directory. Please
use the input box “Current directory is:” to change the directory from where
you want to load the attribute file. If an attribute file is chosen the Load
button is activated and can be pressed to load the attribute file into MAGI.
Note that the attribute file references the model it is associated with, and as
such the model will be loaded, too.
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Result visualization

MAGI is capable of displaying results of a simulation. The results need
to be given in the following format:

• Version n.m

• Title of Data

• {Boundary—Volume} data keyword

• data dimension spatial dimension

• topological dimension

• number data values listed

• data value1

• data value2

• . . .

• . . .

The meaning of the statements is as follows:

• Version number is used for software compatibility/maintenance. The
current version described here is 1.0

• Title is used by the visualization software for labeling spectrums or
other graphics

• “Boundary” means the data is only for the boundary of the geometric
entities.

• data dimension is the tensor order of the data (0-scalar, 1-vector. . . )

• spatial dimension is the n-space in in which the data exists (e.g. 3 for
3-space)
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• topological dimension is the dimensionality of the geometric entities on
which the data is defined, 0-verticies, 1-edges, 2-faces. . .

• number data values listed is the count of data values lines to follow

• The data values to be displayed follow, one per line, e.g. for vectors
in 3 space on the verticies over the Surface of a simple cube with no
interior face vertices would have 3 reals per line, and a total of 8 lines
(one per corner.)

As an example a possible input file looks like this:

Version 1.0
Grid Error Indicator
Boundary
0 3
0
371
0.983995
0.188767
1
0.485353
0.407393
0.264575
. . .
. . .

To display the results simply choose

File→Load Mesh Data File

MAGI will directly display the data file after the correct file has been
selected in the file selector box.
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Trouble shooting

A compilation of common error messages or problems and resolution rec-
ommendations is given here. In case you receive an error message from MAGI
that does not give you enough information to reach a conclusion about the
events that triggered the error message you can see if the error message and
its common causes is described in this section. If you can’t find an answer
to your problem please email softwaresupport@scorec.rpi.edu.

MGI is not built for modeler xxx
You have tried to run MAGI for a modeler that is not supported by
your version of MAGI. If you have a license for that specific mod-
eler please check make sure that the spelling of the modeler is as
expected by MAGI. A list of valid modeler options and the corre-
sponding spelling is given section

mgi: command not found
The system could not find the executable for MGI. Please make sure
the path to the executable is in the search path of your shell. Ask
your system administrator for help if you can’t resolve this problem

Application initialization failed: no display name and no $DIS-
PLAY environment variable (followed by further error messages)

The environment variable $DISPLAY is not set correctly. It needs to
be set to either “DISPLAY=:0.0” if you are starting MAGI on your
workstation, or to “DISPLAY=:machine:0.0” if you are working re-
motely on a workstation where “machine” represents the full internet
address of your computer.

Xlib: connection to “machine:0.0” refused by server
Your local computer does not allow remote machines to display the
MAGI window on the screen. Use xhost +mgiServerAddress, where
mgiServerAddress is the internet address of the computer mgi is run-
ning on, to grant the server access to your display.
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